polygon holes

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

polygon holes

Sean M. Montague
I just upgraded to PostGIS 1.0, and I'm having a problem exporting
polygons with holes, lakes with islands for instance.  I was not having
problem before with version 0.9. Am I missing something?  Thanks.

Sean
_______________________________________________
postgis-users mailing list
[hidden email]
http://postgis.refractions.net/mailman/listinfo/postgis-users
Reply | Threaded
Open this post in threaded view
|

Re: polygon holes

strk
On Mon, Jun 06, 2005 at 10:30:16AM -0600, Sean M. Montague wrote:
> I just upgraded to PostGIS 1.0, and I'm having a problem exporting
> polygons with holes, lakes with islands for instance.  I was not having
> problem before with version 0.9. Am I missing something?  Thanks.
>
> Sean

By "exporting" you mean pgsql2shp usage ?
Can you tell us exact version of PostGIS (postgis_full_version)
and RCSID of pgsql2shp (call w/out args) ?

--strk;
_______________________________________________
postgis-users mailing list
[hidden email]
http://postgis.refractions.net/mailman/listinfo/postgis-users
Reply | Threaded
Open this post in threaded view
|

RE: polygon holes

Sean M. Montague
In reply to this post by Sean M. Montague
1.0.1. I am exporting from ArcView 3.3 with a script I wrote.  My
constructed export statement looks like this:

INSERT INTO "test_02" ("objectid","name","layer","the_geom")
VALUES ('1','1','1',GeometryFromText('MULTIPOLYGON(((-290334 1359643,
-290334 1600755, 5121 1600755, 5121 1359643, -290334 1359643))((-221218
1433507, -94067 1433507, -94067 1531640, -221218 1531640, -221218
1433507)))',32767))

The response I get is: " ERROR:  parse error - invalid geometry"

Thanks.

Sean

-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of
[hidden email]
Sent: Monday, June 06, 2005 10:51 AM
To: PostGIS Users Discussion
Subject: Re: [postgis-users] polygon holes

On Mon, Jun 06, 2005 at 10:30:16AM -0600, Sean M. Montague wrote:
> I just upgraded to PostGIS 1.0, and I'm having a problem exporting
> polygons with holes, lakes with islands for instance.  I was not
having
> problem before with version 0.9. Am I missing something?  Thanks.
>
> Sean

By "exporting" you mean pgsql2shp usage ?
Can you tell us exact version of PostGIS (postgis_full_version)
and RCSID of pgsql2shp (call w/out args) ?

--strk;
_______________________________________________
postgis-users mailing list
[hidden email]
http://postgis.refractions.net/mailman/listinfo/postgis-users
_______________________________________________
postgis-users mailing list
[hidden email]
http://postgis.refractions.net/mailman/listinfo/postgis-users
Reply | Threaded
Open this post in threaded view
|

RE: polygon holes

Sean M. Montague
In reply to this post by Sean M. Montague
That did it, thanks.

-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of
[hidden email]
Sent: Monday, June 06, 2005 11:18 AM
To: PostGIS Users Discussion
Subject: Re: [postgis-users] polygon holes

On Mon, Jun 06, 2005 at 10:59:41AM -0600, Sean M. Montague wrote:
> 1.0.1. I am exporting from ArcView 3.3 with a script I wrote.  My
> constructed export statement looks like this:
>
> INSERT INTO "test_02" ("objectid","name","layer","the_geom")
> VALUES ('1','1','1',GeometryFromText('MULTIPOLYGON(((-290334 1359643,
> -290334 1600755, 5121 1600755, 5121 1359643, -290334
1359643))((-221218
> 1433507, -94067 1433507, -94067 1531640, -221218 1531640, -221218
> 1433507)))',32767))
>
> The response I get is: " ERROR:  parse error - invalid geometry"

It is invalid, you need a comma between components POLYGONS.
Old postgis acceptance of this syntax was a surplus (bug actually).
--strk;

>
> Thanks.
>
> Sean
>
> -----Original Message-----
> From: [hidden email]
> [mailto:[hidden email]] On Behalf Of
> [hidden email]
> Sent: Monday, June 06, 2005 10:51 AM
> To: PostGIS Users Discussion
> Subject: Re: [postgis-users] polygon holes
>
> On Mon, Jun 06, 2005 at 10:30:16AM -0600, Sean M. Montague wrote:
> > I just upgraded to PostGIS 1.0, and I'm having a problem exporting
> > polygons with holes, lakes with islands for instance.  I was not
> having
> > problem before with version 0.9. Am I missing something?  Thanks.
> >
> > Sean
>
> By "exporting" you mean pgsql2shp usage ?
> Can you tell us exact version of PostGIS (postgis_full_version)
> and RCSID of pgsql2shp (call w/out args) ?
>
> --strk;
> _______________________________________________
> postgis-users mailing list
> [hidden email]
> http://postgis.refractions.net/mailman/listinfo/postgis-users
> _______________________________________________
> postgis-users mailing list
> [hidden email]
> http://postgis.refractions.net/mailman/listinfo/postgis-users
_______________________________________________
postgis-users mailing list
[hidden email]
http://postgis.refractions.net/mailman/listinfo/postgis-users
_______________________________________________
postgis-users mailing list
[hidden email]
http://postgis.refractions.net/mailman/listinfo/postgis-users
Reply | Threaded
Open this post in threaded view
|

Re: polygon holes

strk
In reply to this post by Sean M. Montague
On Mon, Jun 06, 2005 at 10:59:41AM -0600, Sean M. Montague wrote:

> 1.0.1. I am exporting from ArcView 3.3 with a script I wrote.  My
> constructed export statement looks like this:
>
> INSERT INTO "test_02" ("objectid","name","layer","the_geom")
> VALUES ('1','1','1',GeometryFromText('MULTIPOLYGON(((-290334 1359643,
> -290334 1600755, 5121 1600755, 5121 1359643, -290334 1359643))((-221218
> 1433507, -94067 1433507, -94067 1531640, -221218 1531640, -221218
> 1433507)))',32767))
>
> The response I get is: " ERROR:  parse error - invalid geometry"

It is invalid, you need a comma between components POLYGONS.
Old postgis acceptance of this syntax was a surplus (bug actually).
--strk;

>
> Thanks.
>
> Sean
>
> -----Original Message-----
> From: [hidden email]
> [mailto:[hidden email]] On Behalf Of
> [hidden email]
> Sent: Monday, June 06, 2005 10:51 AM
> To: PostGIS Users Discussion
> Subject: Re: [postgis-users] polygon holes
>
> On Mon, Jun 06, 2005 at 10:30:16AM -0600, Sean M. Montague wrote:
> > I just upgraded to PostGIS 1.0, and I'm having a problem exporting
> > polygons with holes, lakes with islands for instance.  I was not
> having
> > problem before with version 0.9. Am I missing something?  Thanks.
> >
> > Sean
>
> By "exporting" you mean pgsql2shp usage ?
> Can you tell us exact version of PostGIS (postgis_full_version)
> and RCSID of pgsql2shp (call w/out args) ?
>
> --strk;
> _______________________________________________
> postgis-users mailing list
> [hidden email]
> http://postgis.refractions.net/mailman/listinfo/postgis-users
> _______________________________________________
> postgis-users mailing list
> [hidden email]
> http://postgis.refractions.net/mailman/listinfo/postgis-users
_______________________________________________
postgis-users mailing list
[hidden email]
http://postgis.refractions.net/mailman/listinfo/postgis-users