Re: 1.0.1 released

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: 1.0.1 released

David TECHER
Hi Sandro
 
Compilation for 1.0.1 works fine on Windows XP....
 
Notices:
 
- PostgreSQL 8.0.2 was used
 
- Proj 4.4.9 is detected
 
- Geos is not detected (I needed to add option  '--with-geos' for configure)
 
 
 
But I only have question... Since we needed PostgreSQL sources for the moment,
I think it's better to let postgis-users to be used to using PostgreSQL sources
before a later postgis' version for which we won't have to use PostgreSQL sources.
 
Perhaps for 1.1.0 or a 1.2.0 version...Just let us find and take times for others small  bugs before a such version?
 
What do U think
---------------------------------------------------------------
TECHER Jean David
01MAP
e-mail: [hidden email]
Tél: 04 67 45 60 27
Entreprise: http://www.01map.net
Perso: http://techer.pascal.free.fr/postgis/
---------------------------------------------------------------
----- Original Message -----
Sent: Tuesday, May 24, 2005 8:53 PM
Subject: [postgis-users] 1.0.1 released

Postgis 1.0.1 is out.
You can get it from: http://postgis.refractions.net/download/

Changes since 1.0.0:

        - BUGFIX in shp2pgql escape functions
        - BUGFIX in 3d computation of lenght_spheroid
        - better support for concurrent postgis in multiple schemas
        - documentation fixes
        - BUGFIX in join selectivity estimator returning invalid estimates (>1)
        - jdbc2: compile with "-target 1.2 -source 1.2" by default
        - NEW -k switch for pgsql2shp
        - NEW support for custom createdb options in postgis_restore.pl
        - BUGFIX in pgsql2shp attribute names unicity enforcement
        - BUGFIX in Paris projections definitions
        - postgis_restore.pl cleanups

Have fun!

--strk;
_______________________________________________
postgis-users mailing list
[hidden email]
http://postgis.refractions.net/mailman/listinfo/postgis-users

_______________________________________________
postgis-users mailing list
[hidden email]
http://postgis.refractions.net/mailman/listinfo/postgis-users
Reply | Threaded
Open this post in threaded view
|

Re: 1.0.1 released

strk
On Wed, May 25, 2005 at 12:08:09PM +0200, Jean David TECHER wrote:
> Hi Sandro
>
> Compilation for 1.0.1 works fine on Windows XP....

Thanks for the report!

> Notices:
>
> - PostgreSQL 8.0.2 was used
>
> - Proj 4.4.9 is detected
>
> - Geos is not detected (I needed to add option  '--with-geos' for configure)

You are not supposed to use 'configure' at all :-P
Anyway, I did so to make --with-geos or --with-jts explicit choices
(which one to use in case both are detected ?).

> But I only have question... Since we needed PostgreSQL sources for the moment,
> I think it's better to let postgis-users to be used to using PostgreSQL sources
> before a later postgis' version for which we won't have to use PostgreSQL sources.
>
> Perhaps for 1.1.0 or a 1.2.0 version...Just let us find and take times for others small  bugs before a such version?
>
> What do U think

1.0.x branch will continue to work as 1.0.0: pgsql sources required,
no "autoconf" (if not for hackers which won't tell anyone ;).

1.1.x branch will probably have "autoconf" and all goodies (unless
we get stuck and fall back - but we have time for that).

--strk;

_______________________________________________
postgis-users mailing list
[hidden email]
http://postgis.refractions.net/mailman/listinfo/postgis-users