Postgis version for v10

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Postgis version for v10

Ahsan Hadi
Hi,

According to the Postgis compatibility matrix, the only version of Postgis that is suppose to work with PG v10 is head of Postgis git repository. The version in the head is 2.4.x, please see the link below for compatibility matrix.


Do we know when the Postgis community is planning to release 2.4 release because that seems to be the only version that works with v10?

Thanks,

--
Ahsan Hadi
Snr Director Product Development
EnterpriseDB Corporation
The Enterprise Postgres Company

Phone: +92-51-8358874   
Mobile: +92-333-5162114

Website: www.enterprisedb.com
EnterpriseDB Blog: http://blogs.enterprisedb.com/
Follow us on Twitter: http://www.twitter.com/enterprisedb

This e-mail message (and any attachment) is intended for the use of the individual or entity to whom it is addressed. This message contains information from EnterpriseDB Corporation that may be privileged, confidential, or exempt from disclosure under applicable law. If you are not the intended recipient or authorized to receive this for the intended recipient, any use, dissemination, distribution, retention, archiving, or copying of this communication is strictly prohibited. If you have received this e-mail in error, please notify the sender immediately by reply e-mail and delete this message.

_______________________________________________
postgis-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/postgis-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Postgis version for v10

Regina Obe-2

Ahsan,

 

We are planning to release around the same time as PostgreSQL 10 comes out.  We are going to try a little before 10 so probably around mid – late September.

 

If we decide 2.4 is not ready by end August  (and it seems 10 will be released in Sept as planned), then we'll patch 2.3 to support 10.  We are going to try to avoid that though.

 

Thanks,

Regina

 

From: postgis-users [mailto:[hidden email]] On Behalf Of Ahsan Hadi
Sent: Tuesday, July 25, 2017 8:11 AM
To: [hidden email]
Subject: [postgis-users] Postgis version for v10

 

Hi,

 

According to the Postgis compatibility matrix, the only version of Postgis that is suppose to work with PG v10 is head of Postgis git repository. The version in the head is 2.4.x, please see the link below for compatibility matrix.

 

 

Do we know when the Postgis community is planning to release 2.4 release because that seems to be the only version that works with v10?

 

Thanks,

 

--

Ahsan Hadi
Snr Director Product Development
EnterpriseDB Corporation
The Enterprise Postgres Company

Phone: +92-51-8358874   
Mobile: +92-333-5162114

Website: www.enterprisedb.com
EnterpriseDB Blog: http://blogs.enterprisedb.com/
Follow us on Twitter: http://www.twitter.com/enterprisedb

This e-mail message (and any attachment) is intended for the use of the individual or entity to whom it is addressed. This message contains information from EnterpriseDB Corporation that may be privileged, confidential, or exempt from disclosure under applicable law. If you are not the intended recipient or authorized to receive this for the intended recipient, any use, dissemination, distribution, retention, archiving, or copying of this communication is strictly prohibited. If you have received this e-mail in error, please notify the sender immediately by reply e-mail and delete this message.


_______________________________________________
postgis-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/postgis-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Postgis version for v10

Devrim GÜNDÜZ

Hi,

On Tue, 2017-07-25 at 13:09 -0400, Regina Obe wrote:
> If we decide 2.4 is not ready by end August  (and it seems 10 will be
> released in Sept as planned), then we'll patch 2.3 to support 10.  We are
> going to try to avoid that though.

As I wrote yesterday in a separate thread, we *have to* support 10 in 2.3,
otherwise pg_upgrade will fail.

FWIW, the PostGIS RPMs are shipped with the .so file of X-1 major version to
support upgrades, so I expect 2.3 to be compiled against 10.

BTW, as the packager, I really would prefer to have an *official* alpha/beta
nowadays, as we are about to release PostgreSQL 10 beta3, and did not test
PostGIS RPMS yet.

Thanks!

Regards,

--
Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

_______________________________________________
postgis-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/postgis-users

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Postgis version for v10

Regina Obe-2
Why can't you support 10 in 9.6?

If people install 10 in 9.6, they can then pg_upgrade to 10.

I'm hesitant to support 10 in 2.3 because that would mean we have to support it for the life of 10 and I already made enough changes in 2.4 for 10 that it leaves me a bit hesitant to risk back-porting those changes to 2.3.

Thanks,
Regina

-----Original Message-----
From: postgis-users [mailto:[hidden email]] On Behalf Of Devrim Gündüz
Sent: Tuesday, July 25, 2017 5:57 PM
To: PostGIS Users Discussion <[hidden email]>
Subject: Re: [postgis-users] Postgis version for v10


Hi,

On Tue, 2017-07-25 at 13:09 -0400, Regina Obe wrote:
> If we decide 2.4 is not ready by end August  (and it seems 10 will be
> released in Sept as planned), then we'll patch 2.3 to support 10.  We
> are going to try to avoid that though.

As I wrote yesterday in a separate thread, we *have to* support 10 in 2.3, otherwise pg_upgrade will fail.

FWIW, the PostGIS RPMs are shipped with the .so file of X-1 major version to support upgrades, so I expect 2.3 to be compiled against 10.

BTW, as the packager, I really would prefer to have an *official* alpha/beta nowadays, as we are about to release PostgreSQL 10 beta3, and did not test PostGIS RPMS yet.

Thanks!

Regards,

--
Devrim G nd z
EnterpriseDB: https://www.enterprisedb.com PostgreSQL Danismani/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

_______________________________________________
postgis-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/postgis-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Postgis version for v10

Regina Obe-2
In reply to this post by Devrim GÜNDÜZ
Typo I meant 2.4 in 9.6 and 9.5

2.4 will support 9.3-10

As a general rule, if we need to make a non-trivial number of changes to support a newer version of PostgreSQL in our code-base, we do not backport those changes to stable PostGIS branches.

Thanks,
Regina


-----Original Message-----
From: Regina Obe [mailto:[hidden email]]
Sent: Wednesday, July 26, 2017 1:12 AM
To: 'PostGIS Users Discussion' <[hidden email]>
Subject: RE: [postgis-users] Postgis version for v10

Why can't you support 10 in 9.6?

If people install 10 in 9.6, they can then pg_upgrade to 10.

I'm hesitant to support 10 in 2.3 because that would mean we have to support it for the life of 10 and I already made enough changes in 2.4 for 10 that it leaves me a bit hesitant to risk back-porting those changes to 2.3.

Thanks,
Regina

-----Original Message-----
From: postgis-users [mailto:[hidden email]] On Behalf Of Devrim Gündüz
Sent: Tuesday, July 25, 2017 5:57 PM
To: PostGIS Users Discussion <[hidden email]>
Subject: Re: [postgis-users] Postgis version for v10


Hi,

On Tue, 2017-07-25 at 13:09 -0400, Regina Obe wrote:
> If we decide 2.4 is not ready by end August  (and it seems 10 will be
> released in Sept as planned), then we'll patch 2.3 to support 10.  We
> are going to try to avoid that though.

As I wrote yesterday in a separate thread, we *have to* support 10 in 2.3, otherwise pg_upgrade will fail.

FWIW, the PostGIS RPMs are shipped with the .so file of X-1 major version to support upgrades, so I expect 2.3 to be compiled against 10.

BTW, as the packager, I really would prefer to have an *official* alpha/beta nowadays, as we are about to release PostgreSQL 10 beta3, and did not test PostGIS RPMS yet.

Thanks!

Regards,

--
Devrim G nd z
EnterpriseDB: https://www.enterprisedb.com PostgreSQL Danismani/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

_______________________________________________
postgis-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/postgis-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Postgis version for v10

Devrim GÜNDÜZ
In reply to this post by Regina Obe-2

Hi Regina,

Sorry for the late response, I did not see this email before:

On Wed, 2017-07-26 at 01:11 -0400, Regina Obe wrote:
> Why can't you support 10 in 9.6?
>
> If people install 10 in 9.6, they can then pg_upgrade to 10.

Do you mean 2.4, not 10?

> I'm hesitant to support 10 in 2.3 because that would mean we have to support
> it for the life of 10 and I already made enough changes in 2.4 for 10 that it
> leaves me a bit hesitant to risk back-porting those changes to 2.3.

The history is here:

https://bugzilla.redhat.com/show_bug.cgi?id=1055293


So, here is the scenario:

* There is a PostGIS 2.3 and Postgres 9.6 user, who want to upgrade to Postgres
10, and PostGIS 2.4.

* To perform pg_upgrade, they need 2.3 so file as well in 2.4 installation (see
bug report)

* We fail here, as 2.3 cannot be built against v10.

Regards,

--
Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

_______________________________________________
postgis-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/postgis-users

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Postgis version for v10

Regina Obe-2

> The history is here:

> https://bugzilla.redhat.com/show_bug.cgi?id=1055293


> So, here is the scenario:

> * There is a PostGIS 2.3 and Postgres 9.6 user, who want to upgrade to Postgres 10, and PostGIS 2.4.

> * To perform pg_upgrade, they need 2.3 so file as well in 2.4 installation (see bug report)

> * We fail here, as 2.3 cannot be built against v10.

> Regards,

> --
> Devrim G nd z
> EnterpriseDB: https://www.enterprisedb.com PostgreSQL Danismani/Consultant, Red Hat Certified Engineer
> Twitter: @DevrimGunduz , @DevrimGunduzTR

Devrim,

We recently released PostGIS 2.4.0alpha - http://postgis.net/2017/08/05/postgis-2.4.0alpha/

Is it possible for you to:

1) Create a PostGIS 2.4.0alpha for PostgreSQL 9.6 and 10.0 then what they can do is
a) Do an ALTER EXTENSION postgis UPDATE on their PostgreSQL 9.6 to bring it up to 2.4.0alpha
b) Then do pg_upgrade to PostgreSQL 10

We'll be having upgrade paths from postgis-2.4.0alpha, beta etc. to final when we release

Like I said, I'm hesitant to support 10 on 2.3, because we already ran into a lot of things we had to fix in 2.4. Because of the change in SRFs.
More things might crop up in release time and plus 2.4.0 has many more functions exposed as parallel aware so a better option for PostgreSQL 10 and 9.6 users (especially in 10 now that more strategies are available for parallel).

Thanks,
Regina

_______________________________________________
postgis-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/postgis-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Postgis version for v10

Regina Obe-2
In reply to this post by Devrim GÜNDÜZ
One other option if they really don't want to upgrade their 9.6 to 2.4.0alpha or you really don't want to provide 2.4.0alpha on 9.6.

I don't think we removed any functions in the .so/.dll files only added new ones.  So

1) You provide a PostGIS 2.4.0alpha for PostgreSQL 10
2) They make a copy of that .so file on PostgreSQL 10 and call the copy postgis-2.3.so
3) Then they should be able to pg_upgrade and after pg_upgrading immediately run on their new PostgreSQL 10 install.

ALTER EXTENSION postgis UPDATE;

-----Original Message-----
From: Regina Obe [mailto:[hidden email]]
Sent: Monday, August 07, 2017 1:20 PM
To: 'PostGIS Users Discussion' <[hidden email]>
Subject: RE: [postgis-users] Postgis version for v10


> The history is here:

> https://bugzilla.redhat.com/show_bug.cgi?id=1055293


> So, here is the scenario:

> * There is a PostGIS 2.3 and Postgres 9.6 user, who want to upgrade to Postgres 10, and PostGIS 2.4.

> * To perform pg_upgrade, they need 2.3 so file as well in 2.4 installation (see bug report)

> * We fail here, as 2.3 cannot be built against v10.

> Regards,

> --
> Devrim G nd z
> EnterpriseDB: https://www.enterprisedb.com PostgreSQL Danismani/Consultant, Red Hat Certified Engineer
> Twitter: @DevrimGunduz , @DevrimGunduzTR

Devrim,

We recently released PostGIS 2.4.0alpha - http://postgis.net/2017/08/05/postgis-2.4.0alpha/

Is it possible for you to:

1) Create a PostGIS 2.4.0alpha for PostgreSQL 9.6 and 10.0 then what they can do is
a) Do an ALTER EXTENSION postgis UPDATE on their PostgreSQL 9.6 to bring it up to 2.4.0alpha
b) Then do pg_upgrade to PostgreSQL 10

We'll be having upgrade paths from postgis-2.4.0alpha, beta etc. to final when we release

Like I said, I'm hesitant to support 10 on 2.3, because we already ran into a lot of things we had to fix in 2.4. Because of the change in SRFs.
More things might crop up in release time and plus 2.4.0 has many more functions exposed as parallel aware so a better option for PostgreSQL 10 and 9.6 users (especially in 10 now that more strategies are available for parallel).

Thanks,
Regina

_______________________________________________
postgis-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/postgis-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Postgis version for v10

Devrim GÜNDÜZ
In reply to this post by Regina Obe-2

Hi Regina,

On Wed, 2017-07-26 at 01:44 -0400, Regina Obe wrote:
> Typo I meant 2.4 in 9.6 and 9.5
>
> 2.4 will support 9.3-10

We can do that, but that does not prevent the upgrade problem.

> As a general rule, if we need to make a non-trivial number of changes to
> support a newer version of PostgreSQL in our code-base, we do not backport
> those changes to stable PostGIS branches.

I don't need the features -- I just need a fix to the compiler errors, so that
I can provide the .so file to users.

Regards,
--
Devrim Gündüz
EnterpriseDB: https://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

_______________________________________________
postgis-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/postgis-users

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Postgis version for v10

Regina Obe-2
> Hi Regina,

On Wed, 2017-07-26 at 01:44 -0400, Regina Obe wrote:
>> Typo I meant 2.4 in 9.6 and 9.5
>>
>> 2.4 will support 9.3-10

> We can do that, but that does not prevent the upgrade problem.
Why doesn't this fix the upgrade problem if they UPDATE their PostGIS to 2.4 before doing pg_upgrade


> As a general rule, if we need to make a non-trivial number of changes
> to support a newer version of PostgreSQL in our code-base, we do not
> backport those changes to stable PostGIS branches.

> I don't need the features -- I just need a fix to the compiler errors, so that I can provide the .so file to users.
> Regards,
> --
> Devrim G nd z
> EnterpriseDB: https://www.enterprisedb.com PostgreSQL Danismani/Consultant, Red Hat Certified Engineer
> Twitter: @DevrimGunduz , @DevrimGunduzTR

Any thoughts on my proposal?  I think it will fix your issue now and moving forward.


https://lists.osgeo.org/pipermail/postgis-devel/2017-August/026297.html


Thanks,
Regina

_______________________________________________
postgis-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/postgis-users
Loading...