PSC Vote: Drop Support for PostgreSQL 9.2 in PostGIS 2.4

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

PSC Vote: Drop Support for PostgreSQL 9.2 in PostGIS 2.4

Regina Obe-2
Behavior changes in PostgreSQL 10 are forcing me to change some of the
raster functions.  

Namely this one though there may be others since a lot of raster regression
tests are failing at the moment.

https://trac.osgeo.org/postgis/ticket/3760

To fix the issue, I may resort to things like using LATERAL which was
introduced in PostgreSQL 9.3.

Plus I just want to ditch PostgreSQL 9.2 so we can get rid of some 9.2
checks and not have to test it (we aren't testing it at the moment anyway).

I should also add, that PostgreSQL 9.2 is reaching EOL in September 2017

9.2 9.2.21 Yes September 2012 September 2017

https://www.postgresql.org/support/versioning/

Which is around the same time that PostgreSQL 10 is coming out, and the time
I'd hope we'd be ready to release PostGIS 2.4.



+1 to ditch PostgreSQL 9.2 for PostGIS 2.4

Thanks,
Regina

_______________________________________________
postgis-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/postgis-devel
Reply | Threaded
Open this post in threaded view
|

Re: PSC Vote: Drop Support for PostgreSQL 9.2 in PostGIS 2.4

Bborie Park-2
+1

On Thu, May 25, 2017 at 3:24 PM, Regina Obe <[hidden email]> wrote:
Behavior changes in PostgreSQL 10 are forcing me to change some of the
raster functions.

Namely this one though there may be others since a lot of raster regression
tests are failing at the moment.

https://trac.osgeo.org/postgis/ticket/3760

To fix the issue, I may resort to things like using LATERAL which was
introduced in PostgreSQL 9.3.

Plus I just want to ditch PostgreSQL 9.2 so we can get rid of some 9.2
checks and not have to test it (we aren't testing it at the moment anyway).

I should also add, that PostgreSQL 9.2 is reaching EOL in September 2017

9.2     9.2.21  Yes     September 2012  September 2017

https://www.postgresql.org/support/versioning/

Which is around the same time that PostgreSQL 10 is coming out, and the time
I'd hope we'd be ready to release PostGIS 2.4.



+1 to ditch PostgreSQL 9.2 for PostGIS 2.4

Thanks,
Regina

_______________________________________________
postgis-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/postgis-devel


_______________________________________________
postgis-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/postgis-devel
Reply | Threaded
Open this post in threaded view
|

Re: PSC Vote: Drop Support for PostgreSQL 9.2 in PostGIS 2.4

Paul Ramsey-3
+1, that's a very old db, they can always stick w/ older postgis
P

On Thu, May 25, 2017 at 3:36 PM, Bborie Park <[hidden email]> wrote:
+1

On Thu, May 25, 2017 at 3:24 PM, Regina Obe <[hidden email]> wrote:
Behavior changes in PostgreSQL 10 are forcing me to change some of the
raster functions.

Namely this one though there may be others since a lot of raster regression
tests are failing at the moment.

https://trac.osgeo.org/postgis/ticket/3760

To fix the issue, I may resort to things like using LATERAL which was
introduced in PostgreSQL 9.3.

Plus I just want to ditch PostgreSQL 9.2 so we can get rid of some 9.2
checks and not have to test it (we aren't testing it at the moment anyway).

I should also add, that PostgreSQL 9.2 is reaching EOL in September 2017

9.2     9.2.21  Yes     September 2012  September 2017

https://www.postgresql.org/support/versioning/

Which is around the same time that PostgreSQL 10 is coming out, and the time
I'd hope we'd be ready to release PostGIS 2.4.



+1 to ditch PostgreSQL 9.2 for PostGIS 2.4

Thanks,
Regina

_______________________________________________
postgis-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/postgis-devel


_______________________________________________
postgis-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/postgis-devel


_______________________________________________
postgis-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/postgis-devel
Reply | Threaded
Open this post in threaded view
|

Re: PSC Vote: Drop Support for PostgreSQL 9.2 in PostGIS 2.4

Devrim GÜNDÜZ
In reply to this post by Regina Obe-2

Hi,

On Thu, 2017-05-25 at 18:24 -0400, Regina Obe wrote:
> Plus I just want to ditch PostgreSQL 9.2 so we can get rid of some 9.2
> checks and not have to test it (we aren't testing it at the moment anyway).

I'd also drop support for 9.3 and 9.4. 2.4 users should use a recent PG
version.

Regards,
--
Devrim Gündüz
EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

_______________________________________________
postgis-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/postgis-devel

signature.asc (836 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: PSC Vote: Drop Support for PostgreSQL 9.2 in PostGIS 2.4

Sandro Santilli-3
In reply to this post by Regina Obe-2
On Thu, May 25, 2017 at 06:24:01PM -0400, Regina Obe wrote:

> I should also add, that PostgreSQL 9.2 is reaching EOL in September 2017

[...]

> +1 to ditch PostgreSQL 9.2 for PostGIS 2.4

+1 - thanks for keeping us on the move (I'm getting young) !

--strk;
_______________________________________________
postgis-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/postgis-devel
Reply | Threaded
Open this post in threaded view
|

Re: PSC Vote: Drop Support for PostgreSQL 9.2 in PostGIS 2.4

Regina Obe-2
In reply to this post by Devrim GÜNDÜZ
Devrim,

Wow you are mean :)
I didn't bother proposing that because

1) I figured it would be shot down
2) It seemed especially mean to drop 3 versions in one release.
Though dropping 9.3 is looking tempting.

3) I wanted people if they could to be able to do a pg upgrade from say 9.3 to 10 if they did so choose.
This would not be possible if PostgreSQL 9.3 is not supported in 2.4.

The alternative is to support PostgreSQL 10 on 2.3, which I would much rather not do since we'd then have to make sure 2.3 changes never impact 10 for the life of 10 and there are already quite a few 10 specific changes that would have to be backported to 2.3, possibly destabilizing other lower versions.


I know quite a few folks still on 9.3 sadly but very few on 9.2.  If they are on 9.2, 10 is a steep climb for other breaking reasons anyway so they would probably go 9.4 or 9.5 first before going for 10.
So I figure dropping 9.2 wouldn't impact too many people.

Thanks,
Regina

-----Original Message-----
From: postgis-devel [mailto:[hidden email]] On Behalf Of Devrim Gündüz
Sent: Thursday, May 25, 2017 7:43 PM
To: PostGIS Development Discussion <[hidden email]>
Subject: Re: [postgis-devel] PSC Vote: Drop Support for PostgreSQL 9.2 in PostGIS 2.4


Hi,

On Thu, 2017-05-25 at 18:24 -0400, Regina Obe wrote:
> Plus I just want to ditch PostgreSQL 9.2 so we can get rid of some 9.2
> checks and not have to test it (we aren't testing it at the moment anyway).

I'd also drop support for 9.3 and 9.4. 2.4 users should use a recent PG version.

Regards,
--
Devrim G nd z
EnterpriseDB: http://www.enterprisedb.com PostgreSQL Danismani/Consultant, Red Hat Certified Engineer
Twitter: @DevrimGunduz , @DevrimGunduzTR

_______________________________________________
postgis-devel mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/postgis-devel