Fwd: CREATE EXTENSION postgis returns error

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Fwd: CREATE EXTENSION postgis returns error

Saranya Sari

---------- Forwarded message ----------
From: Saranya Kuniyil <[hidden email]>
Date: Tue, Feb 7, 2017 at 10:02 AM
Subject: CREATE EXTENSION postgis returns error


When I use "CREATE EXTENSION postgis", I'm getting :
curs.execute("CREATE EXTENSION postgis;") psycopg2.InternalError: could not load library "/usr/lib/postgresql/9.5/lib/postgis-2.3.so": /usr/lib/liblwgeom-2.3.so.0: undefined symbol: GEOSClipByRect

Then I try to use

apt-get install liblwgeom-2.3 ....but it shows

Reading package lists... Done Building dependency tree
Reading state information... Done Note, selecting 'liblwgeom-2.3-0' for regex 'liblwgeom-2.3' liblwgeom-2.3-0 is already the newest version (2.3.1+dfsg-1.pgdg16.04+1). The following packages were automatically installed and are no longer required: libcrypto++9v5 libpango1.0-0 Use 'sudo apt autoremove' to remove them. 0 upgraded, 0 newly installed, 0 to remove and 21 not upgraded.


how can I fix it?


Thank you


_______________________________________________
postgis-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/postgis-users
Reply | Threaded
Open this post in threaded view
|

Re: Fwd: CREATE EXTENSION postgis returns error

Sandro Santilli-3
On Tue, Feb 07, 2017 at 10:04:31AM +0530, Saranya Kuniyil wrote:

> apt-get install liblwgeom-2.3 ....
...
> /usr/lib/liblwgeom-2.3.so.0: undefined symbol: GEOSClipByRect

It looks like you're missing a version of GEOS >= 3.5.0.

Would be a bug in the package you're installing, not to list that
as a dependency (libgeos-c >= 1.9.0), check with
`apt-cache show liblwgeom-2.3 | grep Maintainer` who you should ask
to fix that, and meanwhile install a newer GEOS yourself.

--strk;
_______________________________________________
postgis-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/postgis-users
Reply | Threaded
Open this post in threaded view
|

Re: Fwd: CREATE EXTENSION postgis returns error

Saranya Sari
Thank you..


On Tue, Feb 7, 2017 at 2:46 PM, Sandro Santilli <[hidden email]> wrote:
On Tue, Feb 07, 2017 at 10:04:31AM +0530, Saranya Kuniyil wrote:

> apt-get install liblwgeom-2.3 ....
...
> /usr/lib/liblwgeom-2.3.so.0: undefined symbol: GEOSClipByRect

It looks like you're missing a version of GEOS >= 3.5.0.

Would be a bug in the package you're installing, not to list that
as a dependency (libgeos-c >= 1.9.0), check with
`apt-cache show liblwgeom-2.3 | grep Maintainer` who you should ask
to fix that, and meanwhile install a newer GEOS yourself.

--strk;


_______________________________________________
postgis-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/postgis-users